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LUCRAREA 5. Elemente avansate de calcul tabelar. Microsoft Excel -
partea a 2-a

Tema 1: Importul datelor in Excel

Deschideti in Excel fisierul cursvalutar ro.txt. Observati s1 alte formate de fisiere pe care Excel le
poate accesa. Salvafi fisierul in format Excel Workbook (.x1sx) in folderul Documents.

Observafie: Daca setérile regionale (Region and Language din Control Panel) suntin format English
(in sistemul anglo-saxon punctul este separatorul zecimal, iar formatul datei calendaristice este
M/D/Y), deschidef fisierul cursvalutar en.txt.

R:

Meniul File -> Open permite importul datelor din fisiere de diferite formate: fisiere specifice
versiunilor anterioare ale programului Excel (xls), bazelor de date (Access, dBase) sau formatul
OpenDocument Spreadsheet (.ods, format open pentru suite de productivitate), .xml (Extensible
Markup Language, limbaj extensibil de marcare), .html (HyperText Markup Language, pagini Web),
Ixt (fisiere text).

Importul necesita identificarea corectd a informatiilor confinute in fisier: modul de asezare a acestora,
delimitatorul intre coloane, formatul informatiilor (general, datd calendaristicd sau text). Se bifeaza:
"Delimited', My data has headers", "Semicolon" - punct si virguld - ca delimitator al coloanelor.
Formatul se alege pentru prima coloand - Datd calendaristicd (DMY - Day Month Year), pentru
celelalte - General.

Text Import Wizard - Step 1 of 3 HE
The Text Wizard has determined that your data is Fixed Width.
If this is correct, choose Mext, or choose the data type that best describes your data,

—Original data type
Choose the file type that best describes your data:
v Delimited - Characters such as commas or tabs separate 2ach field.
" Fixed width - Fields are aligned in columns with spaces between each field.

Start import at row: |1. 5‘ File arigin: 437 : OEM United States _:j

¥ My data has headers.

Preview of file Chcursvalutar_ro.bxd,

1 pata; EUR; GBP; USD -
E 3.01_2014; 4,4882; 5,4153; 3,2888
3 0&e.01.2014; 4,4547; 5,4068; 3,300%
ﬂ 7-01_2014; 4,5010; 5,4134; 3,2930
ls ha.o1.2014; 4,2979; 5,4342; 3,3106 -

Cancel I Bach I Mext = I Finish

Salvare document: meniul File -> Save si se alege formatul .xlsx.
Tema 2: Grafice (Charts)

2.1. Creafi un obiect de tip grafic (Chart) care sa contini reprezentarile celor 3 valute (EUR, GBP si
USD) Alegetl tipul de grafic Line Chart. Modificafi apot:
titlul; "Curs valutar”;

- culoarea penfru: reprezentanle grafice, textul de pe axe, fundal;

- fontul cu care este scris textul si dimensiunea sa;

- limutele axei verticale intre 3 ... 6, valorile numerice fund afisate cu 2 zecimale;

- directia verticald a textului pentru axa orizontald;

- dimensiunile graficului: lafime 20 c¢m, Indltime 10 cm.
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R:
Se dé click 1n tabelul cu date si se foloseste meniul Insert -> grupul Charts, buton Insert Line Chart
(sau butonul Recommended Charts, Excel va recomanda tipul Line Chart).

12 - = %- 1"

LR SV
Recommended . PivotChart
o - L :

Charts F]

Se da click pe diverse elemente (titlu, axe, fundal, reprezentare graficd etc.) si se modifica
proprietitile din meniul Chart Tools (submeniurile Design sau Format) sau din meniul contextual ->
Format... (pentru axe: lini1 s1 culori de umplere, efecte vizuale, limite, formatare numere etc.; pentru
text: culori, efecte, aliniere).

CHART T0OLS BOOKI - Excel
GRS HOME  INSERT  PAGELAYOUT — FORMULAS  DATA  REVEW  VIEW  DEVELOPER  Acobat  DESIGN | FORMAT
Chart Area - ey — 2 ShapeFill - _ A TextFill - 0 0 E‘ ‘I:I Lﬁ'\ ")k 2l Height: [10.cm
ey A e &
2 Format Selection Oo0ol-| Abc | Abc || Abc Abc | Abc | | Ao | [~ 7 Shape Outline - A A /4\__\_‘ +| B Text Outline = v e 4.3_. el
—| Change — - [/ Y fin end  Selection Align Group Rotate :
“EResettoMatchstyle | L L LI = | & shape Effects - N T [ Eormis Hackaad. Bans. | seop WA e
Current Selection Insert Shapes Shape Styles 5 WordArt Styles [ Arrange Size 5
CHART TOOLS BOOK1 - Excel

FILE HOME INSERT PAGE LAYOUT FORMULAS DATA REVIEW VIEW DEVELOPER Acrobat DESIGN FORMAT

® 1 fin
l '“i* i&" 00 f————| - —— = W e === FC’-‘ Eﬂ l l Eﬂﬂ
Add Chart  Quick Change | Wi | AT R v i PP o [— Switch Row/ Select Change Move
Element ~ Layout - | Colors - . Column Data | Chart Type | Chart
Chart Layouts Chart Styles Data Type Location

Modificare font: click pe Intregul grafic si se folosesc butoanele din meniul Home -> grupul Font.
Limitele axei verticale: click pe axi, din meniul contextual se alege Format Axis -> Axis Options ->
Bounds Minimum: 3, Maximum: 6, apoi Format Axis -> Axis Options -> Number, se alege Category:
Number, Decimal places: 2.

Format Axis ¥ X Format Axis v X
AXIS OPTIONS ¥ | TEXT OPTIONS AXIS OPTIONS ¥ | TEXT OPTIONS
SO o= il A
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Dimensiuni grafic: click pe intregul grafic si din meniul Chart Tools -> Format -> Width, Height.

2.2. Efectuati urmatoarele operatii:

R.

creatl o copie a acestui grafic si afisati doar moneda EUR,;

modificati limitele axei verticale intre 4,3 ... 4.5 si restrangeti perioada de reprezentare (pe axa
orizontald) la luna septembrie. Cum afisati datele calendaristice de pe axa orizontald din 7 in
7 zile (1, 8, 15, 22, 29 septembrie)?

la legendi, 1n loc de "EUR" afisati simbolul €;

schimbati tipul graficului in "Line with Markers". Adaugafti etichete cu valorile
corespunzitoare, conform modelului de mai jos.

Curs valutar
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Dupa ce graticul este duplicat (Copy & Paste), filtrarea datelor afisate se face cu butonul Chart Filters
din dreapta obiectului Chart (cind acesta este selectat) sau din meniul sdu contextual, comanda Select

Data.

Curs valutar

L
Chart data range: | 5|

The data range is too complex to be displayed. If a new range is seledted, it will replace all of the series in the
Series panel,

Legerd Entries (Series) Horizontal {Category) Axis Labels
17 Add EFEdit X Remove v E7 Edit

¥ EUR

r cer
r uso

2 o @ 5
=] =] =] (=] j
s v o a

) Hidden and Empty Cells Cancel

B

pentru Series - axa verticald: se debifeazd GBP s1 USD, iar pentru EUR se editeazd Series
name: € (inserare simbol prin Copy & Paste sau se foloseste combinatia de taste Alt+0128,
cifrele de pe Numpad - partea dreaptd a tastaturii) si Series values intre $B$169:$B$190;
pentru Cafegory - axa orizontald: se selecteazi doar celulele din intervalul 1 ... 30 septembrie
(SA$169:5A5190).
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Afigare la 7 zile: din proprietatile axei orizontale Format Axis se alege categoria Axis Options, apol
Axis Options -> Units -> Major: 7 Days, 1ar minimul $1 maximul trebuie sa fie selectat intre 1
septembrie §1 30 septembrie (stabilite deja).

Schimbare tip grafic: din meniul Chart Tools -> Design -> buton Change Chart Type sau cu click
dreapta pe grafic s1 Change Chart Type.

Dupa schimbare in tipul "Line with Markers" se adauga etichetele: click dreapta pe grafic -> Add
Data Labels. Din proprietatile etichetelor (Format Data Labels - Label Options) se stabileste Text
direction: Rotate all text 270°, Label Contains: Value, Label Position: Above.

Tema 3: Filtrare (Filfer)
Copiati coloanele A...D intr-o noud foaie de lucru (observati numele Sheet! alocat automat celei de-
a doua foi; prima foaie de lucru se numeste cursvalutar ro, nume alocat automat la importul datelor
de la Tema 1).

- filtrati informatile afisate doar pentru luna septembrie;

- afisati doar datele din septembrie in care valoarea EUR a fost intre 4,41 ... 4,42. Cum afigati

toate datele din anul 2014 care indeplinesc aceastd conditie pentru EUR?

R:
Filtrare: click in tabel si meniul Home -> grupul Editing, buton Sort & Filter, comanda Filter sau
meniul Data -> grupul Sort & Filter, buton Filter.

Z AutaSum - "S"W g A B € | O | A : €c | b |
— 7 I ] 1 |[:Ia'ta _'__l EUR|~ | GBP| v | USD| ~ 1 |Data 'lEUR;'__I GEP|~| USD|~
W] Fill ~ Sort & Find & 2| Sort Oldest to Newest :,], Sort Smallest to Largest

£ Clear~ Filter = Select = il S est to Oldest %) Sort Largest to Smallest

Editing

» Sort by Color b

Mumber Filters 3

.|

Cancel |

Din casetele derulante aparute in antetul tabelului se aleg;
- Data: se bifeaza doar luna septembrie
- EUR: Number Filters -> Between -> is greater than or equal to 4,41 AND is less than or
equal to 4,42.
Pentru a afiga toate zilele din an in care valoarea EUR s-a incadrat in intervalul 4,41 ... 4,42, la coloana
Data se bifeaza Select All (sau se sterge filtrul acestei coloane prin Clear Filter From "Data").

Tema 4: Sortare (Sorf)
Anulati filtrele de 1a tema anterioard. Sortati tabelul:
- descrescator dupa valoarea USD;
- dupa 2 criterii simultane: crescator dupd valoarea EUR s1 descrescator dupa Data.
Revenifi in final la sortarea crescatoare dupa data.
R:
Pentru dezactivarea filtrului se apasd butonul Sort & Filter (meniul Home -> grupul Editing ).

4
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Pentru sortare simpla (rapida) dupa coleana USD: click eriunde in coloana USD s1 memul Home ->
grupul Editing, buton Sort & Filter, comanda Sort Largest to Smallest sau memul Data -> grupul Sort
& Filter, buton Sort Largest to Smallest.

ZAutUSUm i é\“r H 2l E T

m Fil Sort & Find & Al Sort Filter -
o , " ¢ Ad d
< Clear Filter = Select - AR
Editi | Sort Smallest to Largest SR Scrites
_l Sort Largest to Smallest

@ Custom Sort...
Y Filter

Pentru sortare complexa (particularizata, cu mai multe criterii simultane si optiuni): click in tabel s1
din meniul Home -> grupul Editing, buton Sort & Filter, comanda Custom Sort sau meniul Data ->
grupul Sort & Filter, buton Sort. In fereastra Sort se modifica sortarea dupa EUR (Order: Smallest to
Largest) si se adauga un nou criteriu de sortare (4dd Level): Data, cu Order: Newest to Oldest.

Sort 2]
"13], Add Level )( Delete Level E@ Copy Level - Options.. v My data has headers
Column |Sort Or |Order I
sort by I EUR LI I\c‘alues _v_I ISmaIIestto Largest ;I
Then by [Data x| |values ¥| [newest to Oldest =]

Cancel I
7l

Tabelul va fi sortat dupa primul criteriu (valoarea EUR, sens crescator), 1ar pentru valori identice va
intra in actiune al doilea criteriu (Data), sens descrescator (de la cea mai recenta la cea mai veche).

Tema 5: Validare. Functia de cautare (LOOKUP). Formatare conditionala
5.1. Copiati antetul tabelului in celulele Gl...J1. Introduceti o conditie de validare in celula G2 care

sd-1 limiteze confinutul la o listd formatd din datele calendaristice din intervalul A2...A205 (vezi
imaginea de mai jos).

S W | 1 |
Data EUR GBP USD
10.01.2014| ¥|4,5447 54874  3,3432

13.01.2014
14,01.2014
15.01.2014
16,01.2014
17.01.2014
20.01.2014
21.01.2014

R:
Se foloseste meniul Data -> grupul Data Tools -> buton Data Validation.
5
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[ o T Data Validation R
<9 = shoE j
B8 == o = 5P, ;
=i - 1 WWEK Settings l Input Message I ErrorAIer‘tI
Text to Rermove IDatla Consolidate What-If e
Columns Duplicates Validation ~ Analysis - Allowr
Data Tools !List ;! ¥ Ignore blank
Dats W In-cell dropdown
Source:
|=sas2:5a5205 I
] ] Apply these changes to all other cells with the same settings
Clear All | oK I Cancel I

Se alege Allow: List, 1ar la Source: A2:A205 (se trage cu mouse-ul peste toate celulele din coloana
A care contin date calendaristice).

5.2. Folosind functia VLOOKUP, obtineti in celulele H2, 12, J2 valorile pentru valutele EUR, GBP
§1 USD corespunzétoare datei calendaristice alese in celula G2 (la schimbarea dater calendaristice se
va modifica g1 confinutul acestor celule).
R:
Sintaxa functiel este:

=VLOOKUP (lookup value, table array, col index num, [range lookup])
unde:
lookup value - valoarea cutati (in cazul nostru, continutul celuler G2);
table array - intervalul de celule unde se face ciutarea, cu conditia ca lookup value si fie in prima
coloani a acestui interval (in cazul nostru, A2:D205),
col _index num - indexul coloanei returnate (a céta coloani din intervalul de celule de mai sus ne
intereseaza) - pentru EUR este coloana 2, pentru GBP coloana 3, iar pentru USD coloana 4;
range lookup - acest parametru optional poate fi "TRUE" (implicit) sau "FALSE" (se foloseste cand
prima coloand nu este sortati In vreun fel, iar funcfia va ciuta valoarea exacti). Deg1 avem ficutd
gortarea dupd data calendaristici, este recomandabil i fologim valoarea "FALSE" pentru a evita
eroarea ce ar apare dacd am avea sortarea dupi o alti coloana (de exemplu, EUR).
In H2, 12 i J2 se vor folosi respectiv formulele:
=VLOOKUP(G2;A2:D205;2; FALSE)
=VLOOKUP(G2;A2:D205;3; FALSE)
=VLOOKUP(G2;A2:D205;4;, FALSE)

5.3. Aplicati o formatare conditionala celuler H2 care sa aiba fundal rosu daca valoarea continuti este
mai mare decét media valutelr EUR (coloana B), respectiv fundal verde daca valoarea este mai mica
decit media.

G H | J G H 1 | J
Data EUR GBP usD Data EUR GBP usD
08.01.2014 4,4579 5,4342 3,3106 10.07.2014 4,3552 5,5199 3,2242

R:

Formatarea condifionala se creeazi din meniul Home -> grupul Styles, buton Conditional Formatting.
Se alege Highlight Cells Rules -= Greater Than, iar in fereastra urmitoare, in locul unei valori, se
introduce formula =AVERAGE(B:B) s1 Light Red Fillwith Dark Red Text. Similar pentru Less Than,
culoarea Green Fill with Dark Green Text.
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(#]
Formatting ~

;) Highlight Cells Rules

Table ~

& ]
Ee) Top/Bottom Rules

ata Bars

i

i Icon Sets
[E] New Rule...
[F8 ClearRules

|E] Manage Rules...

# | Normal
a e
Conditional Format as Ex|

2

3

Bad Go

onatory ... EF

|
|_EI Greater Than...

L_[E—ll Equal To...

Text that Contains...
E

I A Date Occurring...

I Duplicate Values...

More Rules...

Greater Than

Format cells that are GREATER THAN:

L2 x|

|=AvERAGE®:B)

] with |Light Red Fill with Dark Red Text = |

o ]

Cancel I

Less Than

Format cells that are LESS THAN:

|=AVERAGE(B:E)

8] with |Green Fill with Dark GreenText = |

[ o ]

Cancel l

Pentru crearea unei reguli noi se foloseste comanda New Rule, iar pentru gestionarea regulilor
existente (modificare, stergere), comanda Manage Rules.

Conditional Formatting Rules Manager HE
Show farmatting rules for: [Current Selection -
| [E] Mew Rule... [ Edit Rule... < Delete Rule -

Rule (applied in order shown) | Format Stop If True

AaBbCcYyZz

Applies to
=5H52 =

Cell Value > AVERAGE(B... AaBbCcYyZz

=5HS2 & -

OK l Close Apply

Edit Formatting Rule

Select a Rule Type:

| = Format all cells based on their values

= Format only top or bottom ranked values

= Format only values that are above or below average
= Format only unique or duplicate values

= Use a formula to determine which cells to format

Edit the Rule Description:

Format only cells with:

Cell Value =] [iess than =] [=AveracE®:s |
Preview: AaBbCcYyZz | Format...

s |

Tema 6: Tabele pivot (Pivor Table)
Folosind datele din coloanele A...D, creati 2 tabele pivot avand la baza urmatoarele modele:

EUR 43867
Row Labels Count of Data
02.07.2014 1
07.07.2014 1
Grand Total 2

R:

Row Labels Count of Data
4,3845 1
4.3847 1
4.3867 2

Grand Total 204

Se foloseste meniul Insert -> grupul Tables, buton Pivot Table. Se selecteaza toate celulele din
coloanele A ... D si se indica o celula in cadrul foii de lucru in care sa fie plasat tabelul centralizator.

i)

[ =

PivotTable Recommended Table
PivotTables

Tables
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Create PivotTable e B L M N

Choose the data that you want to analyze [ .l

i Salect a table or range

Table/Range: is-heeu!SASL:snszos Eﬂ

L Use an external data source To build a repor‘! choose
L]

st | fields from the PivotTable

onnedian nam e

Field List

Choose where you want the PivotTable report to be placed

{ MNew Worksheet

' Existing Warksheet

Logation: [Sheet1!sis1 i =

Choose whether you want to analyze multiple tables E

[ Add this data to the Data Model -

o
QK | Cancel |

F

Dupi ce Excel creeazi tabelul pivot, cele 4 campuri (Data, EUR, GBP si USD) pot fi trase (Drag &
Drop) in una din urmitoarele zone: Filters, Columns, Rows, Values (la click pe tabel, in panoul
PivotTable Fields).

Pentru a obtine tabelele pivot din cele 2 modele de mai sus se plaseazd campurile astfel:

Zona | .
Mode Filters | Rows | = Values
1 EUR | Data Data
2 EUR Data

intrebari
1. Cetipuri de grafice sunt disponibile in Excel?
2. Cediferente sunt intre sortare si filtrare?
3. Ce criterii existd pentru validarea datelor dintr-o celuli?

R:
1. Tipurile de grafice in Excel sunt disponibile in meniul Insert -> Charts: Column, Bar, Surface,
Line, Area, Combo, Pie, Scatter.

2. Sortarea ordoneazi datele dupd criteriul ascendent/descendent, fardi a ascunde date. Filtrarea
afiseazd doar datele care corespund unui criteriu, celelalte fiind ascunse (filtrate).

3. Implicit, o celuld poate contine orice informatie (text sau numeric). Aceasta poate fi restrictionati
la: un numdr (intreg sau zecimal), o dati calendaristic, un timp (toate acestea intre o valoare minima
s1 maximd), o listd de celule sau valoarea unei formule.
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